Wisdom-soft logo   
 

MotionStudio FAQ 

  Step-by-Step Guides
Support Blog
Flash video guides

  Interaction / EXE Questions
  Operations
   Importing / Editing images
   Other


MotionStudio 4 Answers
 Interaction / EXE Questions


If I create an EXE, and send it by email, will the other end need MotionStudio?

No. The EXE you created is the only file that needs to be sent. No DLLs or any other file is required. The EXE works on Win95 and later.


If an object's action is set to run an external EXE or BAT program, when I make an EXE, what do I need to do with the external EXE or BAT program?

You need to distribute those external programs along with the MotionStudio-created EXE file. MotionStudio does not import any external EXE or BAT programs set in the Actions/Run Program. External files can be EXE's, PDF files or any file can be run by double-clicking.

If you plan to run an external program from a MotionStudio-created EXE file, we recommend that you place the external program in the same folder as the MotionStudio-created EXE file is. In the actions dialog box, only put the file name of the external file, no path. Then, distribute them all together.

The "Setup.msf" sample file located in the Samples400 folder shows a way to run external programs.


I made an EXE file and copied it to a CD to distribute. How do I make the EXE run automatically after inserting the CD into the drive (auto-run)?

Create a text file, but name it "autorun.inf". In the text file, write the following text,

[autorun] 
open=MyEXE.exe 
icon=MyEXE.exe

'MyEXE.exe' is the EXE file name you want to auto-run. Copy the EXE to your CD's root folder.

You can find this file in the "Samples400" folder.

 Operations

How do I add a new frame to a MotionStudio file?

A MotionStudio file has many frames. Although you work on one frame at a time, all frames can be navigated and shown when played. You can,

  • Click the Add New Frame button on the Standard toolbar
    - Or -
  • Press Ctrl + Insert
    - Or -
  • Choose Add New Frame from the Frame menu

Note: In an unlicensed copy, maximum allowed frame number is 3.


How do I make an image transparent?

There are two ways in MotionStudio to change the image transparency.

(1) Transparent Color. Every image can have a "Transparent Color". Once a transparent color is picked, say white, anywhere on the image with this color, white in this case, will be 100% transparent. This can be used to create 100% transparent animation.

Press "Alt" and "Enter" to show the Property Sheet.

E.g.

(2) Opacity. Every image has a property called "Opacity". Opacity has a range of 0 to 100. 0 means completely invisible and 100 means completely visible. Any value between 0 to 100 will be translucent and blended.

Note: "Transparent Color" and "Opacity" are mutually exclusive. That is, if a Transparent Color is picked, there is no effect on Opacity anymore.


What is a translucent object, and how to change the properties?

For a drawing object,  rectangle, circle, line, brush line, if the "Drawing Style" property is set to "Translucent", the object will be show in the translucent mode.

Press "F4" to show the Property Sheet. You can find the "Drawing Style" property and choose between "Opaque" and "Translucent".


How do I select more than one object?

Hold down the Ctrl key and click the objects you need to select.
The first selected object handle color is blue, and the other following objects are green. Formatting is based on the first selected object.


How do I select more than one frame?

Frame List shows all the frames. If Frame List is not visible,

  • Click the Frame List button on the Standard toolbar
    - Or -

  • Press Shift+F1

In Frame List, 
To select non-sequential frames, hold down the Ctrl and click frames to add one by one.
To select a series of frames, hold down the Shift key and click the start and end frame.


How do I add objects to a library file?

1. Select your objects (hold down Ctrl for multi-selection), or group them together so they are in one group.
2. Hold down Alt and drag the selected objects onto the library window. Then drop the objects.
3. A new object icon should be created in the library. You may change the name by clicking the name below the icon. You can then just drag the object from the library and add to any frame.


How do I add frame actions?

Adding frame actions is an easy way to add frame level effects to animate your frames. There are 48 built-in effects to choose from with speed options.

To add frame actions,

  • click the Add Frame Actions button on the Standard toolbar.
    - Or -

  • Choose Add Frame Actions the Frame menu.


Can I copy objects from MotionStudio file A to file B?

Yes. In just two steps,
1. In MotionStudio file A, select the objects you need to copy (hold down Ctrl for multi-selection), and press Ctrl+C, or choose Copy from the Edit menu.
2. Open file B by clicking the Open button on the toolbar or choose Open... from the File menu. Go to the frame you want to have the objects copied, and press Ctrl+V. Or choose Paste from the Edit menu.


How do I add a return (newline) in a Text object?

Hold down the Shift key and press Enter when editing a text object.

 Importing / Editing images


How come some pictures cannot be drag & dropped from the browser? How do I import?

If a picture has an Hyperlink set, such as jumping to another page when clicked, the picture cannot be drag & dropped. You can right-click the picture to save or, capture it using the ScreenHunter way.

To import, 
(1) Right-click the picture and choose Properties from the browser pop-up menu. In the Properties box, highlight the Address:(URL) part and press Ctrl+C
.
(2) In MotionStudio, click the Image tool button. In the Open File dialog box, click the File name field to set the focus. Then, press Ctrl+V to paste the address.
(3) Click Open to import.


Why is that an MSF file has a big file size?

When an image is imported to MotionStudio, say a JPEG file, it is converted to a bitmap file internally. This is because MotionStudio provides the ability to edit any image bit-by-bit. Using Image Editor, double-clicking the image, you can edit any part of the image.

 Other

Where are the sample and library files after installation?

Sample and library files are copied to a sub-folder called "SamplesXXX" found in the folder where the main program is installed. The "XXX" will be the version number.

To load a sample, choose Open... from the File menu, and locate the .MSF (MotionStudio File) file in the folder.

To open a library file, choose Open Library... from the Tools menu, and locate the .MSL (MotionStudio Library) file in the folder.



How is a backup file named?

When the "Automatically take a backup of the original .MSF file before saving" checkbox on the Options/General tab is checked, MotionStudio will automatically take a backup of the original file before saving.

The backup file name format is, 

(original file name)_backupXXX.MSF

where "_backupXXX" is added to the original file name. XXX is a sequential number starting from 1.


How do I add a shortcut of MotionStudio on the desktop?

If you don't want to find the program and manually make it, you can reinstall MotionStudio and check "Add a Shortcut to Desktop" in the "Destination Location" dialog box. If you reinstall in the same directory, all MotionStudio settings will not be changed.

If that cannot be done for any reason, you can always do it manually by these easy steps,

To add a shortcut on the desktop
1. Click the Windows Start button, find and highlight MotionStudio in the menu (don't click). 
2. Right-click and choose 'Create Shortcut' from the menu. A new MotionStudio (2) menu item should be added to the menu.
3. Highlight the newly created menu item, drag it and drop on your desktop.

To add in the Startup group
1. Using the above steps to create a shortcut on desktop.
2. Copy the shortcut to the following folder according to your OS,
     (For Win95/98) {your windows folder}\Start Menu\Programs\StartUp
     (For WinNT) {your windows folder}\Profiles\All Users\Start Menu\Programs\Startup
     (For Win2000/XP) {your windows drive C or D}:\Documents and Settings\{your profile}\Start Menu\Programs\Startup.


What happened to the Internet plug-in that version 3.0 had?

It is determined that Internet plug-in, ActiveX support, is no longer viable for MotionStudio files. Hence, we have discontinued supporting this feature. Instead, MotionStudio will focus on providing high quality interactive EXE creation to enhance your PC experience.

Features are reviewed from time to time, that is our goal to provide users with best value, easy-to-use with a low cost.

 


 

Sitemap  Products  Order  Support  Community  About Us  Contacts  Careers  News  Legal Notices  Privacy Policy

Copyright © 2015 Wisdom Software Inc. All rights reserved.
Protected by the copyright laws of the United States, Canada and by international treaties.


  Sitemap  Products  Order  Support  Community  About Us  Contacts  Careers  News  Legal Notices  Privacy Policy

Copyright © 2012 Wisdom Software Inc. All rights reserved.
Protected by the copyright laws of the United States, Canada and by international treaties.